AnsweredAssumed Answered

Configuring a serial device (ttyS1) for UART? LS1021A-TWR Rev.2

Question asked by Dat Ho on Mar 4, 2016
Latest reply on Mar 16, 2016 by Dat Ho


I'm currently using an LS1021A-TWR rev 2.0 board, QorIQ SDK 1.9, and CodeWarrior for arm v7 10.0.7. I've enabled UART functionality on the RCW and programmed it into the board. However I'm having trouble getting anything transmitted across the UART pins (specifically UART2_TXD and RXD).

 

When I run "setserial -g /dev/ttyS*" there's 4 devices listed: ttyS[0-3]. For S0 and S1 the UART is undefined, port is 0, and IRQ is 118.

 

When I run "dmesg | grep tty", I get :

"ttyS0 at MMIO 0x21c0500 (irq = 118, base_baud = 9375000) is a  16550A_FSL64,"

"ttyS1 at MMIO 0x21c0600 (irq = 118, base_baud = 9375000) is a  16550A_FSL64,"

and "ttyLP0 at MMIO 0x2950000 (irq = 112, base_baud =6250000) is a FSL_LPUART."

 

A custom board based on the LS1021A-TWR, is currently being developed with an external device attached to UART2_TXD and UART2_RXD. I'm trying to get the UART2 TxD and RxD up and running so that I can read and write via UART on these pins. I tried to run setserial /dev/ttyS1 uart 16550 to get the uart to define itself, but that has no effect. Is there a way for me to use the UART pins via UART drivers (not as GPIO)? Do I need to configure the U-boot to get a serial device to connect to the UART pins?

Outcomes