AnsweredAssumed Answered

Problems with yocto repo sync for sabresd platform.

Question asked by Gautam Bhat on Feb 22, 2016
Latest reply on May 18, 2016 by Sam Kunun

Hi,

I am trying to use yocto for the sabresd platform. I am behind a corporate firewall and can use git over http only. In the Freescale Yocto project users guide in the "Yocto Project Setup"  I have done the following:

 

repo init -u  http://git.freescale.com/git/cgit.cgi/imx/fsl-arm-yocto-bsp.git -b  imx-3.14.52-1.1.0_ga

repo syc

 

I have modified the manifest file to include http instead of git links. It is as follows:

  <remote fetch="http://git.freescale.com/git/cgit.cgi/imx" name="fsl-release" />
  <remote fetch="http://git.yoctoproject.org/git" name="yocto"/>
  <remote fetch="https://github.com/Freescale" name="freescale"/>
  <remote fetch="https://github.com/openembedded" name="oe"/>
  <remote fetch="https://github.com/OSSystems" name="OSSystems"/>
  <remote fetch="https://github.com/meta-qt5"  name="QT5"/>

 

Can somebody please review the above edit? I get the following error:

 

Fetching projects:  33% (3/9)  Fetching project meta-fsl-bsp-release

...

...

fatal: http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release/info/refs not valid: is this a git repository?

fatal: http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release/info/refs not valid: is this a git repository?

error: Cannot fetch meta-fsl-bsp-release.18 MiB | 58.00 KiB/s  

Outcomes