AnsweredAssumed Answered

KDS 3.0 Builder Makefile changes

Question asked by Todd Wild on Feb 21, 2016
Latest reply on Feb 21, 2016 by Todd Wild

I have a project that I've imported to KDS 3.0 that was written in KDS 2.0. When I try to build the project I run into a compiler error.

 

arm-none-eabi-g++ -mcpu=cortex-m0plus -mthumb -O0 -fmessage-length=0 -fsigned-char -ffunction-sections -fdata-sections  -g3 -T "MKL46Z256xxx4_flash.ld" -Xlinker --gc-sections -L"C:/Users/Todd/KDS/lab2_timer_stopwatch_with_blank/Project_Settings/Linker_Files" -Wl,-Map,"lab2_timer_stopwatch.map" -nanolibc -o "lab2_timer_stopwatch.elf"  ./Sources/slcd.o ./Sources/stopwatch.o  ./Project_Settings/Startup_Code/startup_MKL46Z4.o ./Project_Settings/Startup_Code/system_MKL46Z4.o  

arm-none-eabi-g++: error: unrecognized command line option '-nanolibc'

make: *** [lab2_timer_stopwatch.elf] Error 1

 

After doing some googling it appears that the -nanolibc option should be replaced with --specs=nano.specs --specs=nosys.specs. I open the makefile in KDS 3.0 and make the change to the makefile and save the modified makefile. Then when I go to build the project I get the same error and the make file has been changed back. How do I get the change to the makefile to stay?

Outcomes