AnsweredAssumed Answered

bitbake linux-imx-rt error: Multiple providers virtual/kernel

Question asked by Durmuş Kurtuluş on Feb 18, 2016
Latest reply on Feb 19, 2016 by charles-chau

Hi,

 

I followed "Freescale Yocto Project User's Guide" for "fsl-yocto-L3.14.52_1.1.0-ga".

When the setup is complete (repo init, repo sync, machine setup, etc.) the first thing I did was:

bitbake linux-imx-rt

And it gives the following errors:

ERROR: Multiple .bb files are due to be built which each provide virtual/kernel (/home/durmus/Yocto/fsl-release-bsp_fido/sources/meta-fsl-arm/recipes-kernel/linux/linux-imx-rt_3.14.28.bb /home/durmus/Yocto/fsl-release-bsp_fido/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-kernel/linux/linux-imx_3.14.52.bb).

This usually means one provides something the other doesn't and should.

ERROR: The recipe linux-imx-rt is trying to install files into a shared area when those files already exist. Those files and their manifest location are:

   /home/durmus/Yocto/fsl-release-bsp_fido/build/tmp/sysroots/imx6solosabresd/sysroot-providers/virtual_kernel

Matched in manifest-imx6solosabresd-linux-imx.populate_sysroot

Please verify which recipe should provide the above files.

The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.

ERROR: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.

ERROR: Function failed: sstate_task_postfunc

ERROR: Logfile of failure stored in: /home/durmus/Yocto/fsl-release-bsp_fido/build/tmp/work/imx6solosabresd-poky-linux-gnueabi/linux-imx-rt/3.14.28-r0/temp/log.do_populate_sysroot.8289

ERROR: Task 3 (/home/durmus/Yocto/fsl-release-bsp_fido/sources/meta-fsl-arm/recipes-kernel/linux/linux-imx-rt_3.14.28.bb, do_populate_sysroot) failed with exit code '1'

 

I tried adding PREFERRED_PROVIDER_virtual/kernel = "linux-imx-rt" to my local.conf, but the result is still the same.

 

How can I resolve this issue?

 

Thanks in advance.

Durmus

Outcomes