AnsweredAssumed Answered

BAM problem in MPC5675K

Question asked by Cenk Ozer on Feb 18, 2016
Latest reply on May 3, 2017 by Juliano Sansao

Hi,

 

We want to boot 5675K by using
RappID bootloader. I arrange the config pins as FAB=1, ABS2=1 and ABS0=0
(serial boot from CAN or LIN with autobaud) and i am sure the necessary logic
levels are provided the MCU. When i tried the communicate using RappID bootloader
i am facing the same problem in below link:

https://community.freescale.com/thread/330412?fsrch=1&pageNum=1

 

I tried the solution that is
mentioned in that discussion but result did not change.

 

Also, i saw in other discussion
default password should be swapped because there is C90LC flash in MPC5675K.
However it did not work either.

 

By the way i can see the messages
coming from CAN interface by looking CAN0_RXD pin on demoboard (MPC5675KEVB).
There is no response on the CAN0_TXD. I cannot see anything on the
oscilloscope.

 

I also looked at AN4674 to
understand mechanics of the issue. In my situation, it looks like BAM does not
work as it is supposed to be.

 

I would be very appreciated if you could help. Thank you.

Outcomes