AnsweredAssumed Answered

MX6: IPU1, DI1 doesn't work on parallel port 1

Question asked by Robert Schwebel on Feb 17, 2016
Latest reply on Feb 22, 2016 by Robert Schwebel

Hi,

In our application the IPU1 unit (at offset 0x2400000) should output 24 bit digital RGB through its DI1 to parallel port 1.

What we see is valid HSync and VSync signals (and RGB data signals) at parallel port 1, but no clock, nor a DE signal. Thus our externally connected TMDS encoder does not work.

We checked the physical connection by changing pad EIM_A16 to GPIO and it works as expected. But setting the MUX_MODE of pad EIM_A16 to ALT1 does not output any clock.

 

Are there any known restrictions connecting IPU1, DI1 to parallel port 1?

 

The used SoC pads are:                                                                                                                                                                           

EIM A16 / ALT1 for display clock  --> no signal at the pad                                                                                                                                  

EIM D29 / ALT1 for display DE     --> no signal at the pad                                                                                                                                  

EIM DA11 / ALT1 for display HSYNC --> expected signal at the pad                                                                                                                            

EIM DA12 / ALT1 for display VSYNC --> expected signal at the pad

Outcomes