AnsweredAssumed Answered

KE04Z8 TX Problem

Question asked by David R on Feb 17, 2016
Latest reply on Feb 17, 2016 by Stanislav Arendarik

Hey ,

I using the MKE04Z8 device on my pcb , my problem is that I can't see anything in the line.

I configure the PTA2 as RX PTA3 as TX and used the next basic code:

 

/* Write your local variable definition here */

  byte packet[2]={100,100};

  word sent ;

  byte retval;

  /*** Processor Expert internal initialization. DON'T REMOVE THIS CODE!!! ***/

  PE_low_level_init();

  /*** End of Processor Expert internal initialization.                    ***/

 

 

  /* Write your code here */

  /* For example: for(;;) { } */

  while(1)

  {

  AS1_SendBlock(packet,2,&sent);

   }

 

what I done:

1. I configured the next code on PTB0 and PTB1 and it send data.

2. I took the pin of the PTA3 and disconnected it from the pcb and still no output signal.

3. I tried the code on the FRDM and it worked.

4. I tried it on more then 1 PCB Board with different devices.

5. I work on eclipse code warrior and I tried it on kinetis design studio and still not working.

 

I think that is something on the pin(PTA3) configuration , Any suggestions ?

BTW, The RX line works perfectly and I am attaching picture of the codewarrior window

Thanks,
David

 

 

 

CodeWarrior Windows with TX Problem.jpg

Outcomes