AnsweredAssumed Answered

T4240RDB Fails to mount rootfs from SD card

Question asked by Sareena Karapoola on Feb 10, 2016
Latest reply on Feb 10, 2016 by Sareena Karapoola

Hi,

 

I am trying to boot the T4240RDB from the SD card.  While booting from the SD card, it boots until the mounting of the root file system. Later it fails with the message

VFS: Cannot open root device "mmcblk0p1" or unknown-block(179,1): error -30

Please see the error below.  The SD card (mmcblkp0) has the uImage binaries and the file system. It gets listed as mmcblkp0 as well. However , it is not able to mount from it.

Please suggest how to overcome this. Am I missing anything.?

 

Waiting 7 sec before mounting root device...

md: Skipping autodetection of RAID arrays. (raid=autodetect will force)

VFS: Cannot open root device "mmcblk0p1" or unknown-block(179,1): error -30

Please append a correct "root=" boot option; here are the available partitions:

1f00          131072 mtdblock0  (driver?)

1f01         2097152 mtdblock1  (driver?)

b300         3873792 mmcblk0  driver: mmcblk

  b301         3869696 mmcblk0p1 00000000-01

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,1)

CPU: 13 PID: 1 Comm: swapper/0 Not tainted 3.12.19-rt30-QorIQ-SDK-V1.7+g6619b8b #1

Call Trace:

[c00000017913b8f0] [c000000000008bb0] .show_stack+0x7c/0x1cc (unreliable)

[c00000017913b9c0] [c000000000739c18] .dump_stack+0x84/0xb0

[c00000017913ba40] [c000000000737588] .panic+0xec/0x25c

[c00000017913bad0] [c0000000009e50e8] .mount_block_root+0x25c/0x338

[c00000017913bbb0] [c0000000009e5474] .mount_root+0x150/0x174

[c00000017913bc60] [c0000000009e5690] .prepare_namespace+0x1f8/0x258

[c00000017913bcf0] [c0000000009e4c58] .kernel_init_freeable+0x22c/0x264

[c00000017913bda0] [c000000000001f3c] .kernel_init+0x30/0x10f4

[c00000017913be30] [c000000000000888] .ret_from_kernel_thread+0x5c/0xd4@

Rebooting in 180 seconds..

 

 

The  uboot cmd used is

setenv bootargs root=/dev/mmcblk0p1 rw rootfstype=ext2 rootwait rootdelay=7 console=$consoledev,$baudrate;mmcinfo;mmcinfo;ext2load mmc 0:1 1000000 /boot/uImage;ext2load mmc 0:1 c00000 /boot/uImage-t4240rdb.dtb;bootm 1000000 - c00000

 

 

Hardware : T4240RDB  Ver 2.0

SDK : V1.7

 

Please find attached the  boot log file as well.

 

 

To troubleshoot , I tried booting from the USB as well.

There too , it fails with same error.

 

Please suggest how to move forward.  Thanks in advance for your help.

 

Thanks,

Sareena.

Original Attachment has been moved to: log.zip

Outcomes