AnsweredAssumed Answered

Package not Suppoted in 1.3 from Builder

Question asked by bcamp on Feb 8, 2016
Latest reply on Feb 10, 2016 by bcamp

Hi

 

Ok, so I hop in and use the new packager tool to generate a KSDK 1.3 (not 2.0) tailored to the MK64FN1M0xxx12 family. I download it / unzip in / put it somewhere I can find it. I go into the "new project" tab on KDS and say "create a PE project". Up comes a project, all is well, I go to switch (under hardware view) to my package (the VLL) and up comes the usual red X's relating to the pins all changing. No big deal. Go to pin_mux and hit "change settings". The red X stays on next to the processor. Hmmm .... over to another view, "package not supported by (correct path to the KSDK for this MCU).

 

Must be a PE thing. I try the same thing as a KSDK 1.3 project. Point to the same version of 1.3 and after the same steps, get the same result. Odd how doing the same wrong thing creates the same error message

 

Now I repeat the process using an "old" install of the bad old full KSDK 1.3. It's obviously bad because it's old ... When I do it this time, after the same steps, the process succeeds. The package *is* supported.

 

Everything is up to date. I have the PE "new manifest" 3.0.2 patch installed along with KDS 3.1.0 . No I did not dig into every possible location on the hard drive looking for release notes in odd places.

 

Bob

Outcomes