AnsweredAssumed Answered

Problems booting board with MK21FN1M0VMC12 (K21 family)

Question asked by Manjula Ellepola on Feb 1, 2016
Latest reply on Feb 4, 2016 by Carlos_Mendoza

Hi Community,

 

We built some proto boards based around the above device. When we got the boards we were able to program and run the device without a problem. Then we added some wires to the board (about 10cm) long to connect one of the I2C ports to a different board. The connections are SCL, SDA, OP line and GND. After we added the wires  the engineer switched on the board and it didn't boot. This was done prior to connecting to the other board. That is the wires were hanging freely. Then we tried to connect the debugger and still no luck. The debugger cannot connect and load the program.

 

We then did the same on a second identical board. That is the second board also could be programmed and booted as the first. Then we added the wires and the same thing happened as the first. It seems as if some protection on the chip has been activated when it was booted after the wires were added. This device has got tamper protection and other security mechanisms. Could it be that the free hanging wires induced some voltage that the chip thought was a tamper and locked down the chip? Another possibility is that some of the free hanging wires got shorted, could this have damaged the chip or activated the security?

 

I am interested to see if anyone else has come across something like this and what to do to solve this.

 

Thanks for your help.

 

Manjula

Outcomes