AnsweredAssumed Answered

TWR-K60D100M Ethernet Connection Problem

Question asked by Mike Kay on Jan 31, 2016

I would be very grateful of some advice with the following problem.

I cannot establish a connection between the TWR-K60D100M and my local network using the TWR-SER board Ethernet interface.

I have tried both the ‘eth_to_serial’ and ‘httpsrv’ MQX RTCS examples, plus I have created a new MQX project using the wizard selecting the ‘Add RTCS Support’, ‘Basic Application’, IP type set to ‘DHCP’. The latter of these projects outputs the following info:


Waiting for ethernet cable plug in ... Cable connected

Contacting DHCP server ...

RTCS failed to bind interface with IPv4, error = 1D04


The defines in the main.h are:

#define ENET_IPADDR IPADDR(192,168,1,200)

#define ENET_IPMASK IPADDR(255,255,255,0)

#define ENET_GATEWAY IPADDR(192,168,1,1)  tried also 192,168,0,1


I have also tried a number of IP addresses which are within the router’s range of IP addresses.


The problem seems to be that the TWR-K60D100M is not being issued with an IP address.


The hardware jumpers are set as followers (as per the tower documentation):

TWR-K60D100M               J10 Pins 2-3

TWR-SER                          J2 Pins 3-4 (CLK_SEL)

                                           J3 Pins 2-3 (CLKIN_SEL)

                                           J12 Pins 9-10 (ETH_CONFIG)


I have checked the boards are mounted correctly to the elevator boards (primary/secondary).


Software versions are:

CodeWarrior 10.6.4.

MQX 4.2


I have built the twrk60d100m bsp, psp, rtcs and shell libraries which are stored at:



I can run the simple ‘Hello’ example no problem.

I also have a Freescale license so no problem with compiler limitations.


Thanks in advance,