AnsweredAssumed Answered

IMX6Q error during u-boot load

Question asked by Régis Duménil on Jan 26, 2016
Latest reply on Jan 31, 2017 by Oleh Kravchenko

Hi all,

 

I'm trying to start a Digi CC6 IMX6 into my hardware design.

The CPU reference is CC-WMX-J97C_TN-1.

I'm using usb imx tool to download u-boot file into the internal memory.

The connection between the PC containing the usb imx tool and the CPU is sucessful, but when I start uploading the u-boot, here is the error that i see :

 

config file <./imx_usb.conf>

vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf

vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf

vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf

vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf

vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf

vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf

vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf

vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf

vid=0x066f pid=0x37ff file_name=linux_gadget.conf

config file <./mx6_usb_work.conf>

parse ./mx6_usb_work.conf

15a2:0054(mx6_qsb) bConfigurationValue =1

Interface 0 claimed

HAB security state: development mode (0x56787856)

== work item

filename ../u-boot-imx6/u-boot.imx

load_size 0 bytes

load_addr 0x00000000

dcd 1

clear_dcd 0

plug 1

jump_mode 2

jump_addr 0x00000000

== end work item

Setting boot_data_ptr to 0

main dcd length 2f0

sub dcd length 2ec

 

 

loading binary file(../u-boot-imx6/u-boot.imx) to 177ffc00, skip=0, fsize=47d04 type=aa

out err=-7, last_trans=0 cnt=0x3c00 max=0x400 transferSize=0x400 retry=0

out err=-7, last_trans=0 cnt=0x3c00 max=0x200 transferSize=0x400 retry=1

out err=-7, last_trans=0 cnt=0x3c00 max=0x100 transferSize=0x400 retry=2

out err=-7, last_trans=0 cnt=0x3c00 max=0x80 transferSize=0x400 retry=3

out err=-7, last_trans=0 cnt=0x3c00 max=0x40 transferSize=0x400 retry=4

out err=-7, last_trans=0 cnt=0x3c00 max=0x20 transferSize=0x400 retry=5

out err=-7, last_trans=0 cnt=0x3c00 max=0x10 transferSize=0x400 retry=6

out err=-7, last_trans=0 cnt=0x3c00 max=0x8 transferSize=0x400 retry=7

out err=-7, last_trans=0 cnt=0x3c00 max=0x10 transferSize=0x400 retry=8

out err=-7, last_trans=0 cnt=0x3c00 max=0x8 transferSize=0x400 retry=9

out err=-7, last_trans=0 cnt=0x3c00 max=0x10 transferSize=0x400 retry=10

Giving up

HAB security state: development mode (0x00000000)

 

Do you know I can solve this issue ?

 

Thank you for your help.

Régis

Outcomes