AnsweredAssumed Answered

hi, error "ldb ldb.13: crtc not specified or invalid"

Question asked by wz ca on Jan 26, 2016
Latest reply on Jan 26, 2016 by igorpadykov

Hi, NXP (freescale) support expert,

 

I try to light my lvds panel by a wandboard solo board, I edit the dts and get the error " ldb ldb.13: crtc not specified or invalid",

I think the reason is i place the script: crtcs = <0xf 0x0>; i think it is not correct ,so pls tell me how to write it, looking forward to reply, thanks.

 

my dts is the following, :

 

fb@0 {
   compatible = "fsl,mxc_sdc_fb";
   disp_dev = "ldb";
   interface_pix_fmt = "RGB24";
   mode_str = "LP101WH4-SLAA";
   default_bpp = <0x20>;
   int_clk = <0x0>;
   late_init = <0x0>;
   status = "okay";

    };

   ldb@020e0008 {
   #address-cells = <0x1>;
   #size-cells = <0x0>;
   gpr = <0xa>;
   status = "okay";
   compatible = "fsl,imx6dl-ldb", "fsl,imx53-ldb";
   clocks = <0x2 0x87 0x2 0x88 0x2 0x27 0x2 0x28 0x2 0x29 0x2 0xb8 0x2 0xb9 0x2 0xd1 0x2 0xd2 0x2 0xd3 0x2 0xd4>;
   clock-names = "ldb_di0", "ldb_di1", "di0_sel", "di1_sel", "di2_sel", "ldb_di0_div_3_5", "ldb_di1_div_3_5", "ldb_di0_div_7", "ldb_di1_div_7", "ldb_di0_div_sel", "ldb_di1_div_sel";

 

   lvds-channel@0 {
   reg = <0x0>;
   status = "okay";
   crtcs = <0xf 0x0>;
   fsl,data-mapping = "spwg";
   fsl,data-width = <0x18>;

 

   display-timings {
   native-mode = <0x10>;

 

   LP101WH4-SLAA {
   clock-frequency = <0x44aa200>;
   hactive = <0x556>;
   vactive = <0x300>;
   hfront-porch = <0x50>;
   hback-porch = <0x30>;
   hsync-len = <0x20>;
   vback-porch = <0xe>;
   vfront-porch = <0x3>;
   vsync-len = <0x5>;
   hsync-active = <0x0>;
   vsync-active = <0x0>;
   linux,phandle = <0x10>;
   phandle = <0x10>;
   };
   };
   };

 

   lvds-channel@1 {
   reg = <0x1>;
   status = "disabled";
   };

Outcomes