AnsweredAssumed Answered

TWR-K65F180 UDP echo example: it doesn't work!

Question asked by Drugo Drughi on Jan 22, 2016
Latest reply on Feb 2, 2016 by Iva Dorazinova

Hello community,

 

I have big problems in communicating with my twrk65f180m board using UDP echo example present in KSDK_1.3.0 (it's the "lwip_udpecho_demo" example under "c\Freescale\KSDK_1.3.0\examples\twrk65f180m\demo_apps\lwip\lwip_udpecho_demo\...").

 

I am using MQX RTOS and KDS IDE (so I chose the proper UDP echo example under the path mentioned above).

 

PROBLEM DESCRIPTION

Sending a ping message from the PC, I cannot communicate with the twrk65f180m while it is running this example. The board is not receiving ANY data from the PC (I couldn't block the code with any breakpoint then).

 

MY PC CONFIGURATION

I sent a "ping 192.168.2.102" to the board from the Windows command console (as explained in "Kinetis SDK v.1.3 Demo Applications User's Guide.pdf"). I configured my PC with the fixed IP address = 192.168.2.101, Subnet mask = 255.255.255.0 and Default gateway = 192.168.2.100. I also tried to configured the PC with Default gateway = 192.168.2.101 (i.e. same of the IP address). Here attached you can find a screenshot of my LAN configuration. The software in the tower board is not giving any positive answer to the ping message

I tried to do the same thing with the ping example. Same result, no answer to a ping message.

 

 

Please, can anyone tell me how to make this example working on twrk65f180m?

 

Thanks so much for your

Attachments

Outcomes