AnsweredAssumed Answered

Update U-boot

Question asked by Fabrice LOUVEAU on Jan 20, 2016
Latest reply on Feb 1, 2016 by Fabrice LOUVEAU

Hi everybody,

 

I have an issue to update u-boot on a sabrelite board.

The u-boot version is :

U-Boot 2009.08 (Aug 16 2012 - 10:06:42)

 

I want to use last release of yocto. I f I well understand, I need a more recent version of u-boot to take into account new kernel with device tree.

I prepare a SD card with jethro image using dd.

zcat boundary-eval-image-nitrogen6x-jethro.sdcard.gz | dd of=/dev/mmcblk0 bs=1M

 

I update the 'upgradeu' command to take the script 6x_upgrade into account in place of 6q_upgrade. And I copy u-boot.nitrogen6s and 6x_upgrade script to boot partition.

I also define 'uboot_defconfig':

upgradeu=for disk in 0 1 ; do mmc dev ${disk} ;for fs in fat ext2 ; do ${fs}load mmc ${disk}:1 10008000 /6x_upgrade && source 10008000 ; done ; done
uboot_defconfig=nitrogen6s

 

When I launch command 'upgradeu', I have the following message:

MX6Q SABRELITE U-Boot > run upgradeu
mmc0 is current device
reading /6x_upgrade

1559 bytes read
## Executing script at 10008000
Please set uboot_defconfig to the appropriate value
Loading file "/6x_upgrade" from mmc device 0:1 (xxa1)
Failed to mount ext2 filesystem...
** Bad ext2 partition or disk - mmc 0:1 **
Card did not respond to voltage select!
mmc1(part 0) is current device
MMC: block number 0x1 exceeds max(0x0)
** Can't read from device 1 **

** Unable to use mmc 1:1 for fatload **
** Bad partition 1 **

 

Can someone explain me how to upgrade u-boot correctly ?

Outcomes