AnsweredAssumed Answered

u-boot fails to start on iMX6Q SabreSDP

Question asked by AlexeyT on Jan 13, 2016
Latest reply on Jan 13, 2016 by AlexeyT

Hello community.

 

Tried to build u-boot to check that my HAB stuff is programmed ok etc.

I followed the instrusctions from here: u-boot on the i.MX6 sabre sd platform in a few commands

Downloaded u-boot 2015.10 and built it exactly as described in above link.

Build was done for mx6qsabresd_config and was successfull.

Then I programmed SD card with my newly compiled u-boot.imx and tried booting up my iMX6Q Sabre for Smart Devices reference board.

For unknown to me reason it hangs.

Here is what I see in terminal:

 

U-Boot 2015.10 (Jan 13 2016 - 15:51:28 +0300)

 

CPU:   Freescale i.MX6Q rev1.2 996 MHz (running at 792 MHz)

CPU:   Automotive temperature grade (-40C to 125C) at 37C

Reset cause: POR

Board: MX6-SabreSD

I2C:   ready

DRAM:  1 GiB

 

Then it stops responging, no more messages seen and no reaction to terminal commands.

 

Can someone please siggest what could go wrong?

Is this u-boot version ok or I just picked untested one?

(If so can you please suggest which version runs ok on my board)

 

It would also be great if someone can point me to compiled (and known as working correctly) version of u-boot so I can rule our hardware issues?

 

Thanks,

Alexey

Outcomes