AnsweredAssumed Answered

wxGTK GUI utilities do not start

Question asked by Dmitriy Dyomin on Dec 30, 2015
Latest reply on Mar 10, 2016 by Ralph Corderoy

I've cloned a github repo (commit 9b451ed5cfd9e03791145da9ce8230a3c622cc98 of repo usbdm-eclipse-makefiles-build). All dependecies including JDK and wxGTK-3.0 are installed, build seems OK on my gentoo desktop (same applies to qemu VM with cleanly installed debian jessie) after minor changes in Common.mk (i've replaced USBDM_LIBDIR64="$(PWD)/PackageFiles/lib/x86_64-linux-gnu").

However, when I try to launch ./MemoryDump/UsbdmMemoryDump-debug.x86_64/UsbdmMemoryDump-debug, I only get the following messages:

 

(usbdm:29848): Gtk-WARNING **: gtk_disable_setlocale() must be called before gtk_init()

20:05:13: Debug: Adding duplicate image handler for 'Windows bitmap file'

 

If I run it in gdb, I have the following stack trace after Ctrl-C:

 

(gdb) bt

#0 0x00007ffff489ff20 in poll () from /lib64/libc.so.6

#1 0x00007ffff341cb6c in ?? () from /usr/lib64/libglib-2.0.so.0

#2 0x00007ffff341cef2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0

#3 0x00007ffff42220bc in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0

#4 0x00007ffff6a638c5 in wxGUIEventLoop::DoRun (this=0x700eb0) at /usr/src/debug/x11-libs/wxGTK-3.0.2.0-r1/wxPython-src-3.0.2.0/src/gtk/evtloop.cpp:65

#5 0x00007ffff5f55a60 in wxEventLoopBase::Run (this=0x700eb0) at /usr/src/debug/x11-libs/wxGTK-3.0.2.0-r1/wxPython-src-3.0.2.0/src/common/evtloopcmn.cpp:78

#6 0x00007ffff5f110e6 in wxAppConsoleBase::MainLoop (this=0x6ac9a0) at /usr/src/debug/x11-libs/wxGTK-3.0.2.0-r1/wxPython-src-3.0.2.0/src/common/appbase.cpp:334

#7 0x00007ffff5fae4c0 in wxEntry (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/x11-libs/wxGTK-3.0.2.0-r1/wxPython-src-3.0.2.0/src/common/init.cpp:495

#8 0x0000000000412675 in main (argc=1, argv=0x7fffffffd758) at src/MemoryDumpApp.cpp:86

 

Could you please help me with this issue?

 

P.S. Sorry for asking the same question here (already tried on sourceforge.net, but got no reply)

Outcomes