AnsweredAssumed Answered

Problem trying to access Internal Flash of MPC565

Question asked by Muhammad Kaleem on Dec 29, 2015
Latest reply on Jan 4, 2016 by Lukas Zadrapa

We have been using MPC565MVR56 for the last 10 years (with Code Warrior and Lauterbach Trace32 debugger) and everything worked fine. This time we got a new lot of MPS565MVR56 marked Rev D . In this lot we are facing problem of not being able to program the internal flash. we are using the same software and hardware settings as we used for earlier versions (MPS565MVR56 without Rev D). Upon closer inspection of flash register through the debugger we found out that the censor bits have a value of 0x11(meaning information censor), so its in censored mode by default. Is this normal for a new device with Rev D and secondly if its normal how can we change to uncensored mode. So far we tried the method in reference manual but it seems we cant change the value of Censor. It seems to be dependend on IWS (which should be 1 for us to be able to change censor). How do we know what is the value of IWS in our device , secondly how do we remove censor restriction and program the controller if its possible at all, or did we receive a faulty lot. Any help in this regard would be greatly appreciated.

 

Thanks.

Outcomes