AnsweredAssumed Answered

Debug Hang using ARM Launch Pad 2015.Q4 and KDS 3.0.0

Question asked by Kenny Koller on Dec 26, 2015
Latest reply on Jan 2, 2016 by Kenny Koller

Per Erich Styger's instructions I downloaded the latest ARM GCC tools from Launch Pad and created a symbolic link from /Applications/KDS_3.0.0/Contents/toolchain to them. This is on OS X El Capitan.

 

I also upgraded to the latest JLink tools and linked its JLink directory to <KDS_HOME>/segger.

 

Under these conditions I can use .../toolchain/bin/arm-none-eabi-gdb to connect to .../segger/JLinkGDBServer when both are launched from the command line. I can load my test ELF file and step through its simple loop.

 

From KDS this process hangs. It just says "configuring GDB aborting configuring GDB".

 

I exited KDS and had to kill the KDS process from the command line. I launched KDS again and specified a path for the GDB server log file. The output showed that it correctly attaches to the target (FRDM 64 board) and was listening on the expected TCP/IP ports. I tried to connect using arm-none-eabi-gdb but this timed out.

 

I also tried the other way round: I launched GDB server from the command line and told KDS not to launch GDB server. When I ran the debugger it got 99 or 100% and hung as usual but I did not see any connection in the server's output.

 

Everything works just fine with the original install. Any ideas?

 

Thanks,

 

Kenny

Outcomes