AnsweredAssumed Answered

Java programs not running on TQMP2020

Question asked by Mike Green on Dec 18, 2015
Latest reply on Dec 22, 2015 by Pavel Chubakov

I have set up a TQMP2020 to boot from SD card using the files on here: en:power:tqmp2020:linux [TQ Support Wiki]

The P2020 boots and I am able to browse the file system and do other operations successfully. However I have been so far unsuccessful in launching java programs successfully.

 

I have downloaded the embedded Java which i assume is compatible with the P2020 (ppc e500v2 ejre) and it has been placed on the file system and the PATH variable edited to point to the bin folder. I have also tried symlinking the java binary to the bin directory.

 

When I run

java

It simply hangs. No output will appear no matter how long the program is ran for. The same occurs if I am to run the command with a compiled class file e.g.

java HelloWorld

 

In an effort to troubleshoot the cause of the hang, I found the following when debugging the JVM:

 

When running “./java –version” it will hang for ever, it spawns ~3 threads

 

Running a stack trace on those threads I found that 2 are hanging on this call:
“futex(0x10064b44, FUTEX_WAIT, 3, NULL)”

 

And the other thread is looping on a seg fault:

“rt_sigreturn(0x1) = 1208935148

--- SIGSEGV (Segmentation fault^Cntation fault) @ 0 (0) ---

 

 

 

Does anybody here have experience with using Java on this system and could offer advice or suggestions which may help solve this issue?

 

Thank you,

Mike

Outcomes