AnsweredAssumed Answered

problem with segger debugger

Question asked by ZOHAR GOLAN on Dec 8, 2015
Latest reply on Dec 8, 2015 by Marek Neuzil

hi all,

 

I am trying to debug a custom board using KDS 3.0.0 and a segger j-Link ultra+. The board have a Kinetis mk20dn512 device connected in a jtag chain with altera device.

I don't have an hardware problem since I can use PE-Micro debugger in this configuration, and I also can use the segger debugger on this board if I am using the IDE from IAR.

The problem is when I am trying to open the debugger I am getting the following error log

 

 

SEGGER J-Link GDB Server V5.10c Command Line Version

 

 

 

JLinkARM.dll V5.10c (DLL compiled Dec  4 2015 17:25:20)

 

 

 

-----GDB Server start settings-----

 

GDBInit file:                  none

 

GDB Server Listening port:     2331

 

SWO raw output listening port: 2332

 

Terminal I/O port:             2333

 

Accept remote connection:      localhost only

 

Generate logfile:              off

 

Verify download:               on

 

Init regs on start:            on

 

Silent mode:                   off

 

Single run mode:               on

 

Target connection timeout:     0 ms

 

------J-Link related settings------

 

J-Link Host interface:         USB

 

J-Link script:                 none

 

J-Link settings file:          none

 

------Target related settings------

 

Target device:                 MK20DN512XXX10

 

Target interface:              JTAG

 

Target interface speed:        500kHz

 

Target endian:                 little

 

 

 

Connecting to J-Link...

 

J-Link is connected.

 

Firmware: J-Link Ultra Rev.1 compiled Dec  3 2013 14:27:53

 

Hardware: V1.00

 

S/N: 501200180

 

Feature(s): RDI, FlashBP, FlashDL, JFlash, GDB

 

Checking target voltage...

 

Target voltage: 1.79 V

 

Listening on TCP/IP port 2331

 

Connecting to target...ERROR: Bad JTAG communication: Write to IR: Expected 0x1, got 0x5 (TAP Command : 10) @ Off 0xF.

 

 

 

ERROR: Could not connect to target.

 

Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...

 

Shutting down...

 

 

I tried adding the option -jtagconf 0,0 since the kinetis device is the closer to the TDO pin on my board, but I've got the same error

 

Please advise,

Best regards,

Zohar

Outcomes