AnsweredAssumed Answered

linux-imx rel_imx_3.14.28_1.0.0_ga: wrong imx6dl galcore clk setup

Question asked by Nikita Yushchenko on Dec 3, 2015
Latest reply on Dec 16, 2015 by Nikita Yushchenko

Hi

 

While working with custom moard based on imx6s processor and linux-imx rel_imx_3.14.28_1.0.0_ga based kernel, I noticed this in dmesg:

 

[ 1.331535] galcore: clk_get vg clock failed, disable vg!

 

This is caused by setting in arch/arm/boot/dts/imx6dl.dtsi:

 

                gpu@00130000 {

                        ...

                        clocks = <&clks IMX6QDL_CLK_OPENVG_AXI>, <&clks IMX6QDL_CLK_GPU3D_AXI>,

                                 <&clks IMX6QDL_CLK_GPU2D_CORE>, <&clks IMX6QDL_CLK_GPU3D_CORE>,

                                 <&clks IMX6QDL_CLK_DUMMY>;

                        clock-names = "gpu2d_axi_clk", "gpu3d_axi_clk",

                                      "gpu2d_clk", "gpu3d_clk",

                                      "gpu3d_shader_clk";

                        ...

                };

 

This has two items that look wrong:

- "openvg_axi_clk" is missing in clock-names, thus the error message,

- "gpu2d_axi_clk" in clock-names refers to IMX6QDL_CLK_OPENVG_AXI, not to IMX6QDL_CLK_GPU2D_AXI

 

Symmetric settng in arch/arm/boot/dts/imx6q.dtsi does not have these issues.

 

Could someone please comment on this and suggest correct setting for imx6dl.dtsi ?

Outcomes