AnsweredAssumed Answered

Failed to start qemu-kvm on TWR-LS1021A

Question asked by Takumi Shimada on Nov 30, 2015

Hi,

 

I tried to use kvm on TWR-LS1021A according to QorIQ SDK 1.8 Documentation.

 

I worked on QorIQ SDK 1.8.

I used fsl-image-full as host rootfs and fsl-image-virt as guest rootfs.

I configured kernel parameters too.

 

I tried to start qemu-kvm as follows:

`qemu-system-arm -enable-kvm -m 512 -nographic -cpu host -M virt -kernel /boot/zImage -serial tcp::4446,server,telnet -initrd /boot/rootfs.ext2 -append 'root=/dev/ram console=ttyAMA0 earlyprintk' -monitor stdio`

But it outputed only as follows:

```

QEMU 2.2.0 monitor - type 'help' for more information

(qemu) QEMU waiting for connection on: disconnected:telnet::4446,server

```

I tried to connect 0.0.0.0:4446 using telnet, but it failed.

 

I also tried to start guest OS by libvirt as follows:

```

echo "/usr/bin/qemu-system-arm -name kvm -smp 2 -enable-kvm -m 512 -nographic -cpu host -machine type=virt -kernel /boot/zImage -serial pty -initrd /boot/rootfs.ext2.gz -append 'root=/dev/ram0 rw console=ttyAMA0 rootwait earlyprintk' " > kvm.args

virsh domxml-from-native qemu-argv kvm.args > kvm.xml

virsh define kvm.xml

virsh start kvm

```

But it failed:

```

error: Failed to start domain kvm

error: operation failed: domain is no longer running

 

```

 

Why did such errors occurred? Are there any methods to debug this error?

Outcomes