AnsweredAssumed Answered

iMx6, IMx132 MIPI camera ,mipi csi2 can not receive sensor clk! in linux

Question asked by wang wang on Nov 18, 2015
Latest reply on May 6, 2016 by Motti Ng

I use IMX6q as master cpu.

 

I have changed the driver ov5640_camera_mipi.c to adjust my camera IMx132, in linux 3.0.35.

 

The i2c write and read is ok, but after i send the i2c data to change the register of the Imx132 sensor and let it go,

the IMX6 can not receive the clk from sensor.

It tells me mipi csi2 can not receive sensor clk!

The register  MIPI_CSI_PHY_STATE is always 0x200!

MIPI_CSI_ERR1,MIPI_CSI_ERR2 is all 0x0.

I've change the lanes number to 1.

I've read the document Debug steps for customer MIPI sensor.

The sensor's input clk is 24Mhz, the differential clk  is 810Mhz.

I've looked through the mxc_mipi_csi2.c, the command

mipi_csi2_write(info, 0x00000014, CSI2_PHY_TST_CTRL1); is also fit my design in my point.

 

And also i patch linux 3.0.35 , when the hdmi clk is not used, i could have the mclk 24Mhz.

also i've tried the linux 3.10.17, which has patched the hdmi clk problem officially.

 

After i've tried the above, the problem is also unfixed. I don't know the reason.

Who can tell me what else should I try?

Outcomes