AnsweredAssumed Answered

IMX6SL Fails to Boot

Question asked by Robby Madruga on Nov 18, 2015
Latest reply on Nov 18, 2015 by Yuri Muhin

Since this is our first attempt at using a Freescale processor, we'd figure it'd be a good idea to stay as close as possible to the

EVK board (IMX6SLEVK). So we basically took the EVK, stripped it of anything we didn't use, changed to a PMIC that Freescale suggested,

and a couple other parts, but it is basically a stripped down version of the EVK in a different board layout.

 

Once we solved a few of the hardware issues (swapped a memory IO pin with 1.8V, etc), we got the board to calibrate DDR memory.

We then proceeded to attempt to boot Yocto Linux from an SD card is slot SD2, with no success. After some fiddling around with the boot fuses, we got U-Boot to show up.

We just let it try to boot with the default environment, but it hanged after "Starting Kernel...". So we thought it best to whip out the JTAG debugger and see what was going on.

 

After downloading the U-Boot source, compiling it with the appropriate denx toolchain, and loading into the SD card, we again attempted to boot U-Boot.

To make sure that it worked correctly we booted it up on our EVK unit first, which thankfully worked. After trying it on our board however, it threw a data-abort exception

immediately after talking with the PMIC (PFUZE200). It data-aborts in the same place every time in a loop.

 

We had some difficulty in debugging U-Boot, is this because it relocates itself in memory? At what point does it relocate itself? Instead of using the JTAG debugger, should

I litter it with printf's? As you've read, there has been some inconsistencies as to what the error was at each stage of debugging this, which does not inspire confidence.

Any help is appreciated!

Outcomes