AnsweredAssumed Answered

LPUART1 not functioning in LS1021A-IOT Board Rev1

Question asked by Pranav Madhu on Nov 18, 2015
Latest reply on Dec 11, 2015 by PRABIN CA

Hi,

I'm new to yocto projects. I'm having an LS1021A-IOT Board rev1, and yocto sdk v1.8. The UART1 in the board is working properly while using the default RCW.

00000000: 0608000a 00000000 00000000 00000000
00000010: 20000000 08407900 60025a00 21046000
00000020: 00000000 00000000 00000000 00038000
00000030: 20024800 881b1340 00000000 00000000

I've edited the RCW to enable LPUART1 as

00000000: 0608000a 00000000 00000000 00000000
00000010: 20000000 08407900 60025a00 21046000
00000020: 00000000 00000000 00000000 10038000
00000030: 20024800 881b1340 00000000 00000000

While using the modified RCW in our board, we are not getting u-boot as well as filesystem console in UART1, but kernel prints are getting. I've also probed the 1st and 2nd (LPUART1 SIN & SOUT) pin in J17 connector, but I didn't notice any deflection. Can you please help me to solve this problem?

LPUART1 support is enabled in the device tree source

 

in ls1021a.dtsi,

    lpuart0: serial@2950000 {
   compatible = "fsl,ls1021a-lpuart";
   reg = <0x2950000 0x1000>;
   interrupts = <GIC_SPI 80 IRQ_TYPE_LEVEL_HIGH>;
   clocks = <&sysclk>;
   clock-names = "ipg";
   status = "disabled";
  

};

and in ls1021a-iot.dts file as

     &lpuart0 {

         status = "okay";

     };

Outcomes