AnsweredAssumed Answered

Can't find source file in imported project: KSDK 1.3.0/KDS 3.0.0/Win 7

Question asked by Gary Lynch on Nov 10, 2015
Latest reply on Dec 4, 2015 by Gary Lynch

I have incorporated KSDK 1.3.0 into KDS 3.0.0 and have
imported, built, and run an example on my Tower out of the
TWR-K60D100M project collection. I imported the project
without setting the "Copy projects..." option, so assume it
was built and run from the original directory.

 

Next I wanted to tinker with a project after I imported it,
so selected the "Copy projects..." option. The import
appeared to terminate normally, but I couldn't build it, and
when I tried to open a source file I got an error message
indicating it didn't exist.

 

I deleted the project and repeated the process, to no
different result.  I deleted it again, but now the import
fails, giving the diagnostic:

 

  "Some projects cannot be imported because they already
   exist in the workspace"

 

I took a look at the workspace with Windows Explorer. Oddly
enough, the project I tried to delete (plus one other) shows
up in the file pane, but not in the folder pane! I can click
down into it and see that it has no "Sources" sub-folder, in
which my other projects keep their main.c.

IncompleteImport01.png

I have found only sketchy documentation on how projects are
stored by KDS.  Anyone know what's going on here?

Outcomes