AnsweredAssumed Answered

RTSP Streaming Internal data flow error

Question asked by Yohei Itaya on Oct 27, 2015
Latest reply on Nov 5, 2015 by Yohei Itaya

Hi, community.

 

I tried to receive and display a RTSP Streaming from ip camera on i.MX6Q SABRE.

I tried the following GStreamer pipeline, and some cameras works fine.

 

# gst-launch-1.0 rtspsrc location=rtsp://192.168.100.30/profile?token=media_profile1&SessionTimeout=60 ! rtph264depay ! vpudec ! overlaysink overlay-top=384 overlay-left=512 overlay-width=512 overlay-height=384 sync=false

 

But on a specific camera, the following error has happened, and could not run the GStreamer.

 

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://192.168.100.30/profile?token=media_profile1
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (open) Opened Stream
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
Progress: (request) Sent PLAY request
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc1: Internal data flow error.
Additional debug info:
/home/itaya/evm/fsl-release-bsp/imx6solo/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/gstreamer1.0/1.4.1-r0/gstreamer-1.4.1/libs/gst/base/gstbasesrc.c(2933): gst_base_src_loop (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc1:
streaming task paused, reason not-linked (-1)
Execution ended after 0:00:00.077380000
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

 

The error is Internal data flow error, and it seemed pipeline is not linked.

Anyone know, how to solve this problem?

 

Thanks.

Outcomes