AnsweredAssumed Answered

gstreamer(0.10) issue for imx53

Question asked by Ravi Kumar on Oct 27, 2015
Latest reply on Nov 3, 2015 by Ravi Kumar

I am getting error while running gstreamer using VPU. I am working on IMX53 based customized board.

 

 

#gst-launch filesrc location=Avengers.mp4 typefind=true ! aiurdemux ! queue max-size-time=0 ! mfw_vpudecoder ! mfw_v4lsink

(gst-plugin-scanner:786): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libmfw_gst_mp3dec.so': lib_mp3_dec_army

(gst-plugin-scanner:786): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libmfw_gst_aacdec.so': lib_aac_dec_army

(gst-plugin-scanner:786): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libmfw_gst_vorbisdec.so': lib_oggvorbiy

(gst-plugin-scanner:786): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libmfw_gst_aacplusdec.so': lib_aac_decy

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_element_class_add_pad_template: assertion `GST_IS_PAD_TEMPLATE (templ)' failed

_getAndLockVSLock: can not get lock vss_lock!

Can not create/open ipc semphone!

(gst-plugin-scanner:786): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libmfw_gst_audio_pp.so': lib_peq_arm11y

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-plugin-scanner:786): GStreamer-CRITICAL **: gst_value_set_int_range: assertion `start < end' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_element_class_add_pad_template: assertion `GST_IS_PAD_TEMPLATE (templ)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_new_from_template: assertion `GST_IS_PAD_TEMPLATE (templ)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_activate_function: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_activatepull_function: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_activatepush_function: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_chain_function: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_event_function: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_element_add_pad: assertion `GST_IS_PAD (pad)' failed

(gst-launch-0.10:785): GStreamer-CRITICAL **: gst_pad_set_setcaps_function: assertion `GST_IS_PAD (pad)' failed

 

 

I think gstreamer-WARNING are due to absence of the libraries which is shown in the error message itself.

Can you please help to fix the gstreamer-CRITICAL issues.

Outcomes