AnsweredAssumed Answered

Code Warrior Installation Problem (for Ubuntu 14.04)

Question asked by Victor Mazin on Oct 26, 2015
Latest reply on Oct 28, 2015 by lunminliang

Hi,

 

I tried to install CodeWarrior for QorIQ LS Series ARMv7 ISA Linux v10.0.7  (evaluation version)- Offline to Ubuntu 14.04 (LTS, x64).

However I Received a lot of errors during the installation of the dependencies. Please see below.

 

How can I install the CodeWarrior? 

 

 

I followed the instructions: I downloaded the file (CodeWarrior for QorIQ LS Series ARMv7 ISA Linux v10.0.7 - Offline.tar) from Freescale website, extracted the TAR file, opened the new terminal window in the disk1 directory and started   ./setuplinux command.

 

However I got the followed message:

The dependencies could not be automatically installed. Please try to manually install the following dependencies and then restart the installer:

libc6:i386

libgcc1:i386

gcc-4.6-base:i386

libstdc++5:i386

libstdc++6:i386

libgtk2.0-0:i386

 

I attempted to install the dependencies manually as it mentioned in the README file (paragraph 2.13 Ubuntu 13.10 /14.04):

 

# sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

# sudo apt-get update

# sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libgtk2.0-0:i386 libxpm4:i386 libusb-0.1-4:i386 libusb-1.0-0:i386 libuuid1:i386 libxcb1:i386 libnspr4:i386 libglib2.0-0:i386 libxdamage1:i386 libxtst6:i386 libssl0.9.8:i386

 

However I received the list of errors:

E: Package 'libc6:i386' has no installation candidate

E: Package 'libgcc1:i386' has no installation candidate

E: Unable to locate package gcc-4.6-base

E: Couldn't find any package by regex 'gcc-4.6-base'

E: Unable to locate package libstdc++5

E: Couldn't find any package by regex 'libstdc++5'

E: Package 'libstdc++6:i386' has no installation candidate

E: Package 'libgtk2.0-0:i386' has no installation candidate

E: Unable to locate package libxpm4

E: Unable to locate package libusb-0.1-4

E: Couldn't find any package by regex 'libusb-0.1-4'

E: Unable to locate package libusb-1.0-0

E: Couldn't find any package by regex 'libusb-1.0-0'

E: Package 'libuuid1:i386' has no installation candidate

E: Unable to locate package libxcb1

E: Package 'libnspr4:i386' has no installation candidate

E: Package 'libglib2.0-0:i386' has no installation candidate

E: Package 'libxdamage1:i386' has no installation candidate

E: Package 'libxtst6:i386' has no installation candidate

E: Unable to locate package libssl0.9.8

E: Couldn't find any package by regex 'libssl0.9.8'

 

Regards Victor

Outcomes