AnsweredAssumed Answered

i.MX233 mfgtool firmware/kernel does'nt boot

Question asked by Tobias Diendorfer on Oct 27, 2015

Dear community.

 

We are currently developing an custom i.MX233 board based on the evk board schematic.

On the prototype board we have assembled an MicroSD holder, which should be removed in upcomming hardware versions.

The firmware of the board should be flashed over USB/mfgtool on the onboard nand flash.

From MicroSD, a self built GNU kernel 4.2 is booting fine and runs stable for several days!

 

Our issue is that the mfg firmware wont boot on our custom board.

We have tried teh following:

 

  • version mfgtool for windows (USB 3.0 issue):
    All mfgtools < 1.6.2.055 crashed when selecting "Options -> Configuration -> USB ports tab"
    Thats a known USB 3.0 issue, so from now we are using "1.6.2.055" -> problem solved.

 

  • Data Abortr14_ or Undefined Instruction

          When trying to boot the prebuilt mfg firmware (profile: MX23 Linux Update) from mfg tool "1.6.2.004" with "1.6.2.055" we are getting the following errors in the bootlets:

 

               Data Abortr14_ or Undefined Instruction

 

          The uboot/kernel does'nt get loaded at all.

          See attached "DataAbort.log" for a full log.

 

  • done, booting the kernel.

          So we have moved to a newer version of the mfg firmware.
          When trying to boot the prebuilt mfg firmware (profile: MX23 Linux Update) from mfg tool "1.6.2.048" with "1.6.2.055" the kernel gets uncompressed but doesnt boot.

          The last messages are:

 

               Uncompressing Linux...................................................................................... done, booting the kernel.

 

          After looking at the kernel source i could say the above messages are not from bootlets/uboot, they are from kernel.

          So i'll assume the kernel was loaded over USB into the ram, gets called, it uncompressing itself and stuck on calling the uncompressed kernel image.

 

          See attached "done, booting the kernel.log" for a full log.

          I have also built the mfg firmware with LTIB myself from the latest available kernel/ltib 2.6.31 source for i.mx233.
          The result is the same!

 

 

So here are my questions:

 

  • Any hint on why the "old" 2.6.31 kernel wont boot?
  • Could we use our 4.2 kernel as a mfg firmware? Are there any binarys which must run in the mfg firmware (ex. to communicate with the mfg tool to flash the firmware to nand?)

 

Our production should will start soon, please help.

 

Thank you

Tobias

Original Attachment has been moved to: DataAbort.log.zip

Original Attachment has been moved to: done-booting-the-kernel.log.zip

Outcomes