AnsweredAssumed Answered

Problem with lwip / tcpecho

Question asked by Paul Fargotstein on Oct 16, 2015
Latest reply on Oct 28, 2015 by Carlos_Musich

We have a board using the K64 that we're trying to do Ethernet-TCP/IP com using KDS 3.0 with KSDK 1.3.  I've been trying to bring up the lwip demo app tcpecho (bare metal) and I just can't get it to work.  One thing different from the FRDM board is we have a Micrel KSZ8794 non-managed 3-port switch connected to the Ethernet port of the micro.   Since it's non-managed, it should be transparent to the bus.  The code builds and executes.  The PC has a 2nd network card plugged in (Intel I210) and I set the IP address, etc according to the Freescale app note ("Adding lwIP to KDS3.0 Project").  I'm attempting to send messages via the PC app SocketTest v3.0 and monitoring the bus with Wireshark.  When I attempt to connect  (the IP addr is set to 168.192.1.102 and the Port is 7) to the board with TestSocket and I get a time out.  Wireshark says there's no activity from the board, only the PC and I can see the query of the board coming from the PC:

 

45 33.788063000 IntelCor_75:e0:c0 Broadcast ARP 42 Who has 192.168.1.102?  Tell 192.168.1.3

 

I've tried all 3 Ethernet ports.  192.168.1.102 is the address I've set in the code and the gateway and mask are set to 192.168.1.1 and 255.255.255.0 respectively.  The PC is set to IP adr 192.168.1.3.  The mask is 255,255,255,0 and the gateway is blank although I tried all combinations with mask 255,255,0,0 and gateway 192.168.1.1 with the same time out.

 

Any help would be appreciated.

 

-Paul

Outcomes