AnsweredAssumed Answered

Will MFG Tool work in all USB Ports of PC? We are facing issue in that.

Question asked by Praveenkumar I on Oct 15, 2015

Hi Everyone,

  • We are using own custom board based on IMX6Q6 Processor. Sabre-lite board is the reference for our custom board.
  • We also made the custom U-boot for our board and SD3 is our boot device. U-boot is working fine. Currently we are using MFGTool2 to load the U-boot in SD Card.
  • Now the problem is MFG Tool is not working consistently in all USB Ports.
  • Using Windows 7 32-bit PC which is having 2 USB EHCI Root Hubs (Hub1 is having 4 USB Ports and Hub2 is having 2 USB Ports).
  • MFG Tool is always working in Hub2 Ports and always not working in Hub1 Ports. Board is connected with PC using OTG Port.
  • While loading U-boot by MFG, in Device Manager of PC the transaction of device is from HID to Portable devices (E:\ or F:\) in working condition. But if I am trying the MFGTool with Hub1 Ports connected the transcation of device from HID to other devices -> file backed storage gadget. MFG Tool also stucked in "No Device Connected".
  • For testing purpose, I tried in Sabre-lite board with the fresh download of MFG. Only changes did in cfg.ini file. Faced the same problem.
  • Not Working Condition : Target is ready to accept the command from PC(MFG Tool). But PC is not sending. Because target is removed from the PC.
  • For reference I have attached the console window output and MFG Tool log. Both working and not working condition.
  • Please guide us to overcome the issue. Thanks in advance.

 

Regards,

Praveenkumar

Original Attachment has been moved to: cfg.ini.zip

Original Attachment has been moved to: Console-Op-in-Working-Cond.txt.zip

Original Attachment has been moved to: Console-Op-in-Non-Working-Cond.txt.zip

Original Attachment has been moved to: MfgTool-in-Non-Working-Cond.log.zip

Original Attachment has been moved to: MfgTool-in-Working-Cond.log.zip

Outcomes