AnsweredAssumed Answered

Application Installion Issue in Android Lollipop 5.0.2

Question asked by Anjalik Krishna on Oct 10, 2015
Latest reply on Oct 22, 2015 by gusarambula

Hi All,

 

I am into an application development which is similar to su application but an enhanced version of su. So before testing the application,I wanted to check whether the application installation is working fine in Android Lollipop with pm command. Unfortunately I am getting "Failure [INSTALL_FAILED_INVALID_URI] " error.

 

I had initially tried with downloading third party apps and installing them with the pm command. Also I have enabled the option to allow apps from unknown source under Security . Since I was getting the same error,I tried to built the apk for the sample application within the Android BSP. But there also I am getting similiar issue.

 

I made sure the APK is not corrupted,because it is being installed in my mobile with Android Lollipop 5.1 successfully. Also I tried to install the same APK with pm command from kitkat terminal .Here also the app got installed succesfully.

 

I made a lame try to replace the working pm utility of kitkat and give a try on Lollipop, no hope there too.

 

Anybody has successfully installed application using pm install in Android Lollipop 5.0.2?

Outcomes