AnsweredAssumed Answered

Problem using MFG tool for i.MX53 QSB

Question asked by João Ramos on Oct 6, 2015
Latest reply on Oct 13, 2015 by João Ramos

Hi,

 

I started following the "i.MX53_START_Linux_BSP_UserGuide.pdf" and ran into a problem.

 

In section 3, "How to Boot the START Board", when installing the driver, so that the "Freescale i.MX53 USB BulkIO Device" can be found, I get an error stating that, altough the driver was found, a problem occur with an hash or the data might have been tampered with. I searched for solutions and found that there have been reports of problems with USB 3.0 ports, which is my case, since my laptop only has USB 3.0 ports and I am also running Windows 8.1 on it.

 

To test the given solutions, I tried to recognize the board on a laptop with USB 2.0 ports and running Windows 7, which worked, but after the board was found in the device manager, it still wasn't recognized in the MFG tool and an "No USB ports selected" message was displayed on the status.

 

I went to Options->Configuration and when I clicked in USB Ports the MFG tool crashed. This happened both in the original environment (Windows 8.1 with USB 3.0 ports) and the second environment (Windows 7 with USB 2.0 ports).

 

I searched online for solutions but still haven't found one.  I also tried older versions of the MFG tool but the problem persists.

 

And so, I have a few questions:

 

1) Have I missed a step, that is not mentioned in the "i.MX53_START_Linux_BSP_UserGuide.pdf"?

 

2) Is there a workaround to make this work using USB 3.0 ports and run it in Windows 8.1?

 

3) Why does the MFG tool crash when I try to go to the USB Ports?

 

Thank you in advance!

 

Regards,

João Ramos

Outcomes