AnsweredAssumed Answered

Latest Vivante drivers require libstdc++ ABI 3.4.20

Question asked by Dario Freddi on Oct 6, 2015
Latest reply on Oct 13, 2015 by Dario Freddi

Hello,

 

while integrating the new Vivante GPU driver release (5.0.11.p7.1), we found out binaries are now compiled against libstdc++ ABI 3.4.20 instead of the previous 3.4.15.

 

This situation is ridiculous to say the least. You are forcing people to use a toolchain which is AT LEAST GCC 4.9. Do you truly expect everyone to change their toolchain at this point in time? For example, we can't afford to change the toolchain on our platform, and now I seriously worry about you guys randomly releasing an update depending on GCC 5.0, which basically breaks every possible concept of Binary Compatibility.

 

I sincerely hope you can provide an updated build with the old libstdc++ constraints as soon as possible, as this currently holds back one of our product releases.

Outcomes