AnsweredAssumed Answered

Phy 1 not found on mx6sxsabresd eval board

Question asked by Don Lobete on Sep 23, 2015
Latest reply on Jun 27, 2016 by Mo sadri

Hi all,

I'm trying to get uboot running on the mx6sxsabre-sdb board but finding Phy 1 is not coming out of reset. Reading all Fs from the AR8031 phy registers.

 

Built u-boot from git://git.denx.de/u-boot.git with mx6sxsabresd_defconfig and burned the u-boot.imx into an SD card.

 

U-Boot 2015.10-rc3-00213-g1fb8d79-dirty (Sep 23 2015 - 14:03:28 -0700)

 

 

CPU:   Freescale i.MX6SX rev1.0 996 MHz (running at 792 MHz)

CPU:   Extended Commercial temperature grade (-20C to 105C) at 28C

Reset cause: POR

Board: MX6SX SABRE SDB

I2C:   ready

DRAM:  1 GiB

PMIC:  PFUZE100 ID=0x10

MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2

PCI:   pcie phy link never came up

In:    serial

Out:   serial

Err:   serial

Net:   Phy 1 not found

PHY reset timed out

FEC [PRIME]

 

Just get Fs reading mii bus -

 

=> mii dump 1 0 

0.     (ffff)                 -- PHY control register --

  (8000:8000) 0.15    =     1    reset

  (4000:4000) 0.14    =     1    loopback

  (2040:2040) 0. 6,13 =   b11    speed selection = 10 Mbps

  (1000:1000) 0.12    =     1    A/N enable

  (0800:0800) 0.11    =     1    power-down

  (0400:0400) 0.10    =     1    isolate

  (0200:0200) 0. 9    =     1    restart A/N

  (0100:0100) 0. 8    =     1    duplex = full

  (0080:0080) 0. 7    =     1    collision test enable

  (003f:003f) 0. 5- 0 =    63    (reserved)

 

Would appreciate any wisdom if anyone has seen this. Is there newer/better source somewhere ?

 

Thanks in advance,

Don.

Outcomes