AnsweredAssumed Answered

UART TX not connecting to PTA3 pin for the S9KEAZN8AMFK (SKEAZN8MFK4)

Question asked by Kevin Weiss on Sep 21, 2015
Latest reply on Sep 21, 2015 by Jorge_Gonzalez

Problem:  It appears that the UART0 TX is stuck to ground when set to the PTA3 pin (pin 19).  I can see it try to move a few mV on the scope  (which seems like it is contention) but it is always a low value.

 

What I found: It works on the  alternate pin PTB1 (pin 15).  It doesn't work on both our board and the eval board (so I don't think it is externally being pulled down).  It thinks that it transmitted successfully (does not throw any error and timing it correct).

 

What I am using:  The IDE is Kinetis Design Studio v3.0.0.  I am using the Processor Expert to configure (I tried using both the Kinetis/AsynchroSerial and Kinetis/Serial_LDD drivers).

 

It seems to me like the pin is being set internally to an output driven low and connected at the same time to tx from the UART.  This is my first time using a freescale chip and it would be nice not to have to spend a day searching through the reference manual to fix the config problem.  If anyone has any advice it would be greatly appreciated.

 

Thanks,

 

Kevin

 

Well, looks like the PTA2 and PTA3 are open drain.  Just popped in a pullup resistor and it works now, maybe someone will find this info useful.

 

Message was edited by: Kevin Weiss

Outcomes