AnsweredAssumed Answered

Build Error: Please enable allocator or disable MQXCFG_ENABLE_FP

Question asked by Raj Batra on Sep 18, 2015
Latest reply on Sep 21, 2015 by Raj Batra

Hi,

 

I am getting a compile error when building a project for the K64F:

 

C:\Users\raj\Development\lib\Freescale\KSDK_1.2.0/rtos/mqx/lib/frdmk64f.kds/debug/mqx/mqx_cnfg.h:1328:6: error: #error FP tasks need enabled allocator. Please enable allocator or disable MQXCFG_ENABLE_FP.

     #error FP tasks need enabled allocator. Please enable allocator or disable MQXCFG_ENABLE_FP.

 

I did find one instance in which MQXCFG_ENABLE_FP was set to 1. It was in KSDK_1.2.0/rtos/mqx/config/mcu/MK64F12/mqx_sdk_config.h (not sure why, as everywhere else I see it set to 0).

 

So I set it to zero there as well as in my local project which appears to be a copy of it located in Config/mcu/MK64F12/mqx_sk_config.h

 

I rebuilt the mqx_stdlib_frdm64f, and ksdk_mqx_lib_K64F12 but when I rebuild my local project I still get the error message.

It goes away, if I don't include MQX.h in one of my .c files. But I don't know what is triggering the error.

 

Any tips appreciated.

Outcomes