AnsweredAssumed Answered

MC13224V and Beestack Codebase 3.1.1 freeze

Question asked by Cristiano De Alti on Sep 18, 2015
Latest reply on Nov 25, 2015 by Cristiano De Alti

I'm trying to run the Black Box project on my custom mc13224V-based dongle.

The dongle uses an external PA.

 

I've loaded in BeeKit the user defined settings for the dongle which are stored in a xml file.

I've used this file in the past with previous Beekit versions.

 

The Black Box project worked with Beestack 3.0.10.

 

Starting from scratch with BeeKit 3.0.2 and ARM7 Beestack Codebase 3.1.1 does not work for me.

 

The problem is that the Beestack initialization hangs in BeeStackTaskInit() function when initializing the first task of the beeTaskTable.

The task is TS_ApsTask() and the initialization function is TS_ApsTaskInit(). The latter never returns.

 

With the debugger I can see that the program counter is somewhere in FlashLib_Read.

 

If the initialization of this task is skipped,  BeeStackTaskInit() returns normally but of course ZTC does not work.

 

Another thing I've tried is to swap the order of call of BeeStackInit() and Init_802_15_4() in BeeAppInit.c, calling the latter first.

In this case everything starts OK, ZTC works but if I try to start the network with ZTC-StartNwkEx.Request the MAC scan does not complete (I can see with TestTool the call to MAC scan request but no confirm follows).

 

I understand that MC13224V is end of life but I still have many of these dongles and they are useful for certain purposes.

 

Can anyone confirm this issue?

 

Regards,

  Cristiano

Outcomes