AnsweredAssumed Answered

I2C_DRV_MasterInit() getting stuck at OSA_SemaCreate(&master->irqSync, 0) within the function

Question asked by Duane Owens on Sep 15, 2015
Latest reply on Oct 8, 2015 by Duane Owens

Hello, sorry to trouble you for something that will probably be a NOOB issue.  I am running MQX 4.2, KSDK 1.2, KDS 3.0 and have created a test MQX app using Processor Expert to create a couple GPIO drivers, a couple tasks and an I2C driver on I2C1.  Just to begin to get some experience with working with the I2C driver I made a call to I2C_DRV_MasterInit() in the fsl_i2c_master_driver.c and it seems to go into an endless loop at:

Line #103, OSA_SemaCreate(&master->irqSync, 0);

 

I've tried it with enabled I2C interrupts and without but the result is the same.

 

Everything is autogenerated except the call to I2C_DRV_MasterInit() and a couple variables.  I was able to get the GPIO and task stuff to work, but not the I2C.  By the way, I'm calling the I2C_DRV_MasterInit() from the main() function in the main.c file that is autogenerated.   I've tried to keep things real basic to make it easier to troubleshoot.

 

By the way, are there going to be in tutorials for this stuff based upon the latest MQX 4.2, KSDK 1.2, KDS 3.0?  It's confusing because the newer versions appear to do a lot of the low-level setups while there's no examples that match my configuration.

 

Thank you!

Duane

Outcomes