AnsweredAssumed Answered

FRDM-KL46Z doesn't connect using the SWD(J11)

Question asked by Neil Porven on Sep 8, 2015
Latest reply on Sep 9, 2015 by Neil Porven

Hi everyone,

 

I just got my FRDM-KL46Z development board and the pre-programmed functions run on the board.  After

looking at it and playing with the default functions, I decided its time to make something happen.  So, I have

a P&E Multilink (C) and also (B) versions, which I will use to program/configure the eval board.  It is recommended

that J18 is trace between 1&2 is cut to free the OpenSDA from the KL46Z, which I did.

 

I followed a project that came with the KSDK for the peripheral driver SLCD, I connected the P&E Multilink (C) to the

eval board SWD connector and tried to configure the project.  I got an error message (P&E Connection Assitant) "An

error occurred while connecting to the interface hardware or target specified in the Launch Configuation Dialog.

The USB Multilink - USB Port was showing, also on the drop down box, there was information showing the Multilink

that I am using.

 

I thought maybe the cut I made was still making contact, so I ohmed it out and that doesn't seem to be the issue.  I also

made sure that PIN 1 had 3.3V, it had 3.25V which for all intends and purpose should work.  I also made sure tha

SWD_DIO_TGTMCU was connected to PIN 37 on the KL46Z, which checked out good.

 

So, I thought maybe is the project I am following, so I made a test project where I choose to do just the processor, without

the KSDK or PE support.  I got the same result, same message appeared.

 

Am I supposed to cut another trace or something else?  I know that for the FRDM-K64, I had to remove some resistors next

to the SWD connector, but I don't think this one has that issue?

 

Thanks,

Neil

Outcomes