AnsweredAssumed Answered

Why Jumping to "woohoo, idle task must be enabled, this point cannot be reachable" Location?

Question asked by Riju Peter on Sep 3, 2015
Latest reply on Nov 12, 2015 by daafies

Hi,

 

I am facing some strange issues with KDS 3.0 and KSDK 1.2.0. with project created for K64 processor based custom board.

 

I started with a  basic MQX project and found to be working without any issues. In my design I am using UART4 of the micro to interface to an external device. My custom board  could communicate the external device properly.  I am using UART_DRV_SendData/UART_DRV_ReceiveData commands for transferring the data between custom board and external device.

 

But when I tried to debug the project, sometimes the project got stuck and jumped to "woohoo, idle task must be enabled, this point cannot be reachable" location. Once it happens, it won't revert to the normal working condition.

I tried below steps to recover the project.

 

a) Changing the workspace and open the project.. Occasionally it helped to recover the project.

b) Terminate the debugger,rebuild after cleaning the project. But with this also very rarely I could recover the project.

 

I am using pE Micro Multilink Universal debugger.

 

I suspect KDS workspace/project is getting corrupted somehow.

 

Please let me know how to fix this issue?

Greatly appreciate a quick response on this.

 

Regards

Riju

Outcomes