AnsweredAssumed Answered

Can't unsecure/program blank Kinetis - core not running?

Question asked by Jamie Wood on Aug 28, 2015
Latest reply on Sep 2, 2015 by Carlos_Mendoza

I've just assembled a new board with a MK22FN128VLH10, and I'm trying to program it using a modified FRDM-K22F development board (SWD_CLK and SWD_DIO, as well as RESET carried over to programming header on new board).

 

I've successfully programmed one of the boards, which means the circuit / power etc. is at least designed correctly. I've put together the second board (identical to the first) but it refuses to perform a mass-erase from JLink (I'm using the OpenSDA Segger J-Link firmware on the FRDM board).

 

It will identify the device on the SWD bus, and displays the message saying the Kinetis device is secured, so I must perform a mass-erase to unsecure it. When I click yes, there is a pause of a few seconds, then JLink announces that there was a timeout while unsecuring the device. The log also has "Error while identifying Cortex-M core" after this, and when it tries to connect to the device via SWD.

 

I've tried probing the reset line when the FRDM board is disconnected, and I would expect to see it being driven low periodically as the Kinetis faults due to executing invalid instructions. However, the reset line stays high all the time, which seems like the Kinetis core is not actually running (which might explain why it cannot read the information from the Flash to identify the core, or issue the flash-erase commands).

 

Other things I've tried:

  • tested voltage on the 3 VDD pins: all are 3.3v so OK
  • tested continuity between SWD pins and the programming header: all OK
  • connected debugger back to first board (working): not an issue with the debugger.

 

Any ideas on why the core isn't running and why I can't erase it?

Outcomes