AnsweredAssumed Answered

Debian8+SabreSD: Can't enable 3D HW acceleration

Question asked by James Liu on Aug 28, 2015
Latest reply on Dec 10, 2015 by Laszlo Timko

I have spent some days to make a Debian8 system on SabreSD board, begins with Debian on the i.MX6 sabre sd platform in a few commands .

My code base is standard Yocto1.7 package "fsl-yocto-3.14.28-1.0.0" where 3D HW acceleration works fine when I run "es2_info" or demos in fsl_gpu_sdk.

For Linux kernel part, I keep debian same as yocto1.7.

For Rootfs, I move GFX relative libaries from  "fsl-yocto-3.14.28-1.0.0", i.e. imx-gpu-viv, libdrm, mesa-demos, fsl-gpu-sdk, recompiling "xf86-video-imxfb-vivante" natively, set /etc/X11/xorg.conf as,

Section "Device"     
Identifier "i.MX Accelerated Framebuffer Device"
      
Driver  "vivante"
      
Option  "fbdev" "/dev/fb0"
      
Option  "vivante_fbdev" "/dev/fb0"
      
Option  "HWcursor"     "false"

EndSection

then, Vivante xorg driver can make my LXDE desktop work happily.  but when I run  "es2_info", it prints

                        libEGLwarning: DRI2: falied to authenticate

                        EGL_VERSION: 1.4(DRI2)

                        EGL_VENDOR:  Mesa Project

                         ..........

                        GL_VERSION: OpenGL ES2.0 Mesa 10.6.3

                        GL_RENDERER:  Software Rasterizer

                        .........

obviously, OpenGL ES is SW path. Please give some hints on how to enable HW path as Yocto1.7 does.  Thanks.

Yours,

James

Outcomes