AnsweredAssumed Answered

Tutorial for PE with MQX and KDS.

Question asked by Jan R. Seyler on Aug 25, 2015
Latest reply on Aug 28, 2015 by soledad

Hi,

 

I want to develop a firmware with the MQX RTOS. Additionally I want to use KDS for it as this is the IDE we chose over CW because it is newer and more recommended for starting new projects. I am developing on a TWR-K60F120M with the TWR-SER and TWR-ELEV modules.

I worked through a lot of "Getting started" documents and tried to make a new Kinetis project.

I added the CPU first followed by LEDs, a Console, a Wait Module and the two buttons.

 

Till here everything worked perfectly fine and I was able to flash the software to the board and got the desired mooving lights. Now I added MQX (not MQX lite) to the project. Now I can't build it anymore as I get the following error for each BitIoLdd:

In function `BitIoLddX_Init':

../Generated_Code/BitIoLdd3.c:130: undefined reference to `_lwmem_alloc_system'

 

I can find the _lwmem_alloc_system macro in the mqx.h in the built psp library which is also included in the project. But it seems like the linker is not able to make that connection. I don't know if the ordering of the includes might be the problem. But I treid to circument that by using -Xlinker --start-group ${INPUTS} -Xlinker --end-group instead of ${INPUTS}...

 

Additionally I have the problem that I don't really know what to do with the MQX module in PE. I don't see a possibility to add tasks or semaphores. So is it, that the module adds the OS and adapters to it and basically everything else needs to be added by hand?

 

I also tried to load the pe_demo into CW but it doesn't show the PE components. I was just curious to see how that looks like.

 

Well, a lot of questions at once. Maybe someone can help me to solve some of them

 

Thanks,

best regards,

Jan

Outcomes