AnsweredAssumed Answered

How do I disable the MQX FlexCAN driver?

Question asked by Robert York on Aug 20, 2015
Latest reply on Aug 21, 2015 by Robert York

I've been struggling with the MQX 4.1 FlexCAN driver. So far, I've gotten through most of the issues, but I'm getting stuck on receiving data. Rather than bang my head trying to figure it out, It's been suggested I try the PE CAN driver. I've been told it's a lot simpler.  One note I saw was that I need to disable the MQX FlexCAN driver in the user_config.h. However, I can't find any mention of any CAN driver in user_config.h. I had to modify the init_gpio.c file to point to the correct pins for my board, but I don't see anything else about disabling it. Any idea how I stop MQX from initializing it? The only other method I could think of would be to remove the configuration info from init_gpio.c

Outcomes