AnsweredAssumed Answered

How to manually enable CAN RxFifo on KDS2.0 Pexpert?

Question asked by Yaran Nan on Aug 10, 2015
Latest reply on Sep 14, 2015 by isaacavila

Hi,

1. My project is using MK20DC256VLL10 and we found out it drops around 1.5% CAN frames.

2. The project is using KDS 2.0 and processor expert.

3. The project only has one CAN node ID enable.

4. Reference manual mentions that can enable MCR[RFEN] to enable RxFifo. (I am assuming

that is the reason of losing CAN frames).

5. Unfortunately, processor expert doesnt support to enable the feature of enabling RxFifo

6. I saw other people has the same problem in the forum. They suggested to enable manually.

7. I dont quite know how to enable them without effecting codes already generated.

8. Currently, CAN is read when the interrupt flag set up.

 

Does anyone have any suggestion about how to manually enable RxFifo or reduce losing CAN

messages?

 

Thanks,

 

Yaran

Outcomes