AnsweredAssumed Answered

How to include MQX library in KDS instead KSDK....

Question asked by Garima Parashar on Aug 9, 2015
Latest reply on Feb 20, 2016 by Garima Parashar

Hi.,

 

I am working with KDS 3.0.0 and KSDK 1.2.0.

 

Previously I have created a project in CodeWarrior v10.6 with MQX v4.0 which is using RTCS and MFS library.

 

Now I am need to use KDS, so I started to learn @ KDS. I created a New MQX project inside KDS by following Creating a New MQX RTOS for KSDK1.2 Project in KDS3.0.pdf and that works perfectly.

 

Now in the same MQX project, In source folder, I copied my previous project(Which I have created in CodeWarrior using MQX v4.0) source files (say of .c and .h).

 

Now I build project that show me an error that is what I am listing with solutions I made:

1. of "rtcs.h not found" and I include C:\Freescale\KSDK_1.2.0\middleware\tcpip\rtcs\lib\twrk60d100m.kds\debug\rtcs inside ARM C Compiler.

2. Also Solved error of "ethernet.h not found" by including  #include <fsl_enet_rtcs_adapter.h> and  disabling if PLATFORM_SDK_ENABLED portion like:

 

//#if PLATFORM_SDK_ENABLED

//   #include <fsl_enet_rtcs_adapter.h>  /* ENET KSDK adaptter.*/

//#else

//    #include <ethernet.h>   /* ENET driver APU.*/

//    #include <enet.h>       /* ENET driver APU.*/

//#endif

 

3. of "undefined IO_ERROR" that is a return value from send() function, solved by putting false as a return value from send().

 

(I dont know whether I am right or wrong but errors solved...!! )

Here my RTCS errors are finished but series of errors not finishing at this point.

 

Now comes MFS...

 

I also solved so many errors like undefined mfs.h , undefine FILE_PTR, IO_SEEK_SET/IO_SEEK_END etc...

 

Is this compulsory to do this in KDS to use MFS library (in my case)? Isn't there any other way in which i dont need to solved this errors?

 

Errors are coming due to I copied MQX source files. So is there any way to include MQX library instead KSDK? I also have MQX 4.2.

 

Or any other way to use previous MQX and CodeWarrior project.

 

Regards,

Garima

Outcomes