AnsweredAssumed Answered

RTCS from KSDK 1.2 does not build under KDS 3.0 on Windows 7 64-bit

Question asked by Brian Willoughby on Aug 4, 2015
Latest reply on Aug 6, 2015 by ZhangJennie

Background: I have KDS 3.0 installed and compiling firmware for the K64 that runs on my custom hardware platform, using the PE micro Multilink Universal. I am trying to add RTCS to the firmware, but DHCP hangs without returning an error.

 

Current Situation: Someone else compiled lib_rtcs.a, so I thought it would be a good idea to try building that again, in case any options were specified incorrectly. Unfortunately, I cannot get KDS to build RTCS from KSDK 1.2

 

I used "Import from existing project" to load \Freescale\KSDK_1.2.0\middleware\tcpip\rtcs\build\kds\rtcs_frdmk64f and tried to build. I get hundreds of warnings, and an error in a batch file that complains about an unmatched quote. I tried a clean build, but same results. I also tried loading the workspace at \Freescale\KSDK_1.2.0\middleware\tcpip\rtcs\build\kds\workspace_frdmk64f, but it was empty. So, I again imported the existing project above and got the same results.

 

Question: Is KDS 3 supposed to be able to build components of the KSDK 1.2? I would assume that it should be the easiest thing to import one of these projects and build without modifying anything.

Outcomes